Формулы Excel - Да, еще один сайт, но какой?! ETOLEGKO
Без рубрики

Формулы Excel

Содержание

О формулах в Excel

СУММЕСЛИ

ПРОИЗВЕД

ABS

СТЕПЕНЬ

КОРЕНЬ

СЛУЧМЕЖДУ

ЧАСТНОЕ

РИМСКОЕ

LOG

ОСТАТОК

СЧЁТ

Любая формула начинается со знака равенства. 

Ставим знак «=» в ячейке или в строке для формул «fx»

Вот примеры таких формул:

  • сложение – «=A1+A2»;
  • вычитание – «=A2-A1»;
  • умножение – «=A2*A1»;
  • деление – «=A2/A1»;
  • возведение в степень (квадрат) – «=A1^2»;
  • сложносоставное выражение – «=((A1+A2)^3-(A3+A4)^2)/2».

Адрес ячейки в формуле не обязательно вводить вручную, достаточно просто кликнуть левой кнопкой мыши на нужную ячейку. Зная это, можно легко и быстро ввести непосредственно в ячейку или в строку «fx» любое простое выражение, используя только математические знаки и цифры. Более сложные функции задаются с помощью буквенных команд-операторов.

Левой кнопкой мышки выделяем ячейки со значениями между ними ставим нужный математический знак с клавиатуры

Важно! Не забывайте, что любое изменение данных в исходных ячейках приведет к автоматическому пересчету всех связанных с ними формул. Если формат ячейки, на которую ссылается формула, не числовой, программа выдаст ошибку.

На рисунке ниже приведена матрица числовых значений и рассчитано несколько показателей для первой строки:

  • сумма значений: =СУММ(A3:E3);
  • произведение значений: =ПРОИЗВЕД(A3:E3);
  • квадратный корень доли суммы в произведении: =КОРЕНЬ(G3/F3).

 Предположим, что аналогичный расчет нужно выполнить и для остальных рядов. Для этого ячейки с формулами последовательно потянем за правый нижний угол вниз до конца числовых значений.

 Обратите внимание, что курсор превратился в «плюс», а ячейки за ним выделяются пунктирной рамкой. Отпустив кнопку мыши, получим рассчитанные по строкам значения показателей. Автозаполнение можно применять как к отдельной строке или столбцу, так и к крупным массивам данных.

СУММЕСЛИ

Оператор СУММЕСЛИ также подсчитывает общую сумму чисел в ячейках. Но, в отличие от предыдущей функции, в данном операторе можно задать условие, которое будет определять, какие именно значения участвуют в расчете, а какие нет. При указании условия можно использовать знаки «>» («больше»), «<» («меньше»), «< >» («не равно»). То есть, число, которое не соответствует заданному условию, во втором аргументе при подсчете суммы в расчет не берется. Кроме того, существует дополнительный аргумент «Диапазон суммирования», но он не является обязательным. Данная операция имеет следующий синтаксис:

=СУММЕСЛИ(Диапазон;Критерий;Диапазон_суммирования)

ПРОИЗВЕД

Задачей оператора ПРОИЗВЕД является умножение отдельных чисел или тех, которые расположены в ячейках листа. Аргументами этой функции являются ссылки на ячейки, в которых содержатся данные для перемножения. Всего может быть использовано до 255 таких ссылок. Результат умножения выводится в отдельную ячейку. Синтаксис данного оператора выглядит так:

=ПРОИЗВЕД(число;число;…)

ABS

С помощью математической формулы ABS производится расчет числа по модулю. У этого оператора один аргумент – «Число», то есть, ссылка на ячейку, содержащую числовые данные. Диапазон в роли аргумента выступать не может. Синтаксис имеет следующий вид:

=ABS(число)

СТЕПЕНЬ

Из названия понятно, что задачей оператора СТЕПЕНЬ является возведение числа в заданную степень. У данной функции два аргумента: «Число» и «Степень». Первый из них может быть указан в виде ссылки на ячейку, содержащую числовую величину. Второй аргумент указывается степень возведения. Из всего вышесказанного следует, что синтаксис этого оператора имеет следующий вид:

=СТЕПЕНЬ(число;степень)

КОРЕНЬ

Задачей функции КОРЕНЬ является извлечение квадратного корня. Данный оператор имеет только один аргумент – «Число». В его роли может выступать ссылка на ячейку, содержащую данные. Синтаксис принимает такую форму:

=КОРЕНЬ(число)

СЛУЧМЕЖДУ

Довольно специфическая задача у формулы СЛУЧМЕЖДУ. Она состоит в том, чтобы выводить в указанную ячейку любое случайное число, находящееся между двумя заданными числами. Из описания функционала данного оператора понятно, что его аргументами является верхняя и нижняя границы интервала. Синтаксис у него такой:

=СЛУЧМЕЖДУ(Нижн_граница;Верхн_граница)

ЧАСТНОЕ

Оператор ЧАСТНОЕ применяется для деления чисел. Но в результатах деления он выводит только четное число, округленное к меньшему по модулю. Аргументами этой формулы являются ссылки на ячейки, содержащие делимое и делитель. Синтаксис следующий:

=ЧАСТНОЕ(Числитель;Знаменатель)

РИМСКОЕ

Данная функция позволяет преобразовать арабские числа, которыми по умолчанию оперирует Excel, в римские. У этого оператора два аргумента: ссылка на ячейку с преобразуемым числом и форма. Второй аргумент не является обязательным. Синтаксис имеет следующий вид:

=РИМСКОЕ(Число;Форма)

LOG

С помощью этого оператора определяется логарифм числа по заданному основанию. Синтаксис функции представлен в виде:

=LOG(Число;Основание)

Необходимо заполнить два аргумента: Число и Основание логарифма (если его не указать, программа примет значение по умолчанию, равное 10).

Также для десятичного логарифма предусмотрена отдельная функция – LOG10.

ОСТАТОК

Применяется для получения остатка от деления чисел. Формула оператора выглядит следующим образом:

=ОСТАТ(чило;делитель)

Для того, чтобы получить результат, требуется заполнить значения двух аргументов: Число и Делитель.

СЧЁТ

Формула: =СЧЁТ(адрес_ячейки1:адрес_ячейки2)

Англоязычный вариант: =COUNT(A1:A10)

Данная формула подсчитывает количество ячеек с числами в одном ряду. Если вам необходимо узнать, сколько ячеек с числами находятся в диапазоне c A1 по A30, нужно использовать следующую формулу: =СЧЁТ(A1:A30).

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *